Requirements

Operating Systems

Supported

Rivalcfg was made to work on the following systems:

  • Linux (any distribution that use udev, like Debian, Ubuntu, ArchLinux, Fedora,…)

  • Microsoft Windows

Maybe Supported

Rivalcfg should also work on the following systems but they are not aclively supported:

  • MacOS X

  • BSD

Not Supported

The following system are not supported (yet?):

  • Haiku (the hidapi library cannot be installed on this OS for now, it needs to be ported).

  • GNU Hurd

Python Versions

Rivalcfg currently supports

  • Python 2.7 (support will be dropped someday)

  • Python 3.5+